Rocket Chat migration error

Posted on 12-01-2017 by Nadir Latif


Source: https://rocket.chat/docs/administrator-guides/database-migration/

If your Rocket Chat upgrade fails with the error: "Your database migration failed", then you may need to unlock the migration in mongodb and also increase database version to the next version

You can do this by accessing the mongo shell and then entering the rocketchat database using the command: use rocketchat. After that run the command: db.migrations.update({_id: 'control'},{$set:{locked:false,version:19}}). Replace 19 with the current version of your database migration